Community Forums

Find answers, ask questions, and connect with Victory enthusiasts around the world.

Home Forums 2002-2007 Model Years 2006 Vegas rough idle/won’t run

  • 2006 Vegas rough idle/won’t run

    Posted by Garrett on June 6, 2024 at 11:27 pm

    I’ve got a 2006 Vegas. Awhile back it was stolen and after a few weeks recovered. The theif(s) had obviously laid it down but the damage was fairly mild overall, all cosmetic. After getting the bike back it sat for over a year for various different life reasons. I’m now working on getting it rideable again.

    The bike will start but doesn’t fire off immediately like it used to, it takes several seconds of cranking. Once it starts it seems to run ok for a few seconds then the rpms start going wild. It will rev real high then stumble and die unless I start finessing the throttle. I can eventually get it to warm up and idle a little rough but as soon as I put it in gear and let the clutch out it dies and won’t restart once it’s hot.

    I’ve put fresh gas and confirmed its getting good fuel pressure, new spark plugs and confirmed it has a strong spark on both cylinders, new battery, and replaced all the rubber vacuum hoses I can find and even the throttle body adapter thinking maybe it was a vacuum leak. It was suggested to me to try the IAC reset and to confirm that my fast idle lever was working properly, which is seems to be. None of this seemed to make the slightest difference.

    To me it sounds/feels like a timing issue. Is it possible for it to have lost the map somehow? I know very little about efi engines. If this was an old school V8 I’d be busting out the timing light and adjusting the distributor but I have no idea what to do next. Any advice where I should be looking next or what might be wrong with it?

    Garrett replied 1 week, 2 days ago 1 Member · 0 Replies
  • 0 Replies

Sorry, there were no replies found.